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Introduction

CDRDB is a simple database program for storing information about CD images.
This document describes how to configure and use CDRDB.

Before this program was written the Author had many (hundreds probably) of old
slowly deteriorating CD-Rs containing archives and backups in storage. They still
contained useful data but with no index and no way of searching them that data
was virtually inaccessible.

So it was decided as the first stage of a solution to image all of the CD-Rs (make
.iso files of them) and record their details in a database (CDRDB) as the disc im-
ages filename alone could not record enough useful information. CDRDB allowed
the disc images to just be numbered with all useful information being stored in a
database. This means the original CD-Rs, which were slowly going bad, were no
longer required and their contents could easily be indexed in the future using the
disc images.

Because many discs had similar names like "Stuff", "stuff ", "Junk 4", "backup 9,
18/03/2003", etc, the text on the disc alone was not unique enough to identify them.
To solve this problem, each disc was put through a scanner to have a picture taken
of it. This allows entries in the database to be matched up to the physical disc if
needed.

1.1 System Requirements

CDRDB does not require a database server of any kind as it uses the embedded
SQLite3 database engine. As such, all that is required to run the windows version
is Windows XP or newer. Windows 2000 has received minimal testing and CDRDB
appears to work on this version but there may be hidden problems.
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2 CHAPTER 1. INTRODUCTION

It should also be possible to compile and run CDRDB on any platform supported
by Nokias Qt toolkit, version 4.6 or newer. This includes Linux and MacOS X. The
QtGUI and QtSQL modules are required along with the SQLite3 database driver.
These should be included in your Qt installation.
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Main Window

The main window (figure 2.1) shows a table of all the discs in the database along
with the usual menu and toolbar.

Figure 2.1: The Main Window with a database open

Double clicking on an Disc in the table will bring up more information about that
disc (See section 4.2).
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2.1 Menu Items

All of the programs functionality can be accessed through the menu bar at the top
of the main window. Some of these options are also available on the toolbar.

This section gives an overview of all the available menu items and what they do.

2.1.1 File Menu

New Database... Creates a new CDRDB Database file.
Open Database... Opens an existing CDRDB Database file.
Import Disc Hashes... Imports Disc Hashes. See Section 3.1.
Exit Exits CDRDB.

2.1.2 Create Menu

New Disc... Creates a new Disc entry. See Section 4.1.

2.1.3 Tools Menu

Database Properties... Allows database properties to be viewed/edited.
See Section 5.1.

Maintain Media Types... Allows the list of available Media Types to be
edited. See Section 5.2.

Edit Data Allows disc entries to be edited. See Section
4.3.
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Disc Image Handling

CDRDB was originally designed to store detailed information about disc images
(.iso files). To link records in the database up to the actual disc images, CDRDB
uses hashes (MD5, SHA-1, whatever) based on the contents of the image file
instead of file names. This provides the following advantages:

• Files can be renamed without manually changing filenames in the database

• If there is more than one copy of a CD in the database they will share the
same image file automatically. Both entries in the database will show the
same image file(s).

• If duplicate image files are discovered later they can be removed without
affecting the database. The database will just end up showing one image
file instead of two or three identical ones for those entries.

3.1 Importing Hashes

Whenever new discs are added or image files are renamed you need to import a
new set of hashes into the database so that the hashes in the disc records can be
used to look up filenames.

To do this you first need to run a utility like md5sum (included in most linux distros)
or MD5Summer (a GPL graphical utility for Windows - http://www.md5summer.
org) over your directory of disc images. This will produce a .md5 file which looks
like the following:
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803dfa09e126d9b10b890be3317c4585 *DISC3.iso
8d0e39d6c924945a8e3f2621a687a8ea *DISC2.iso
fb955a3db083723cc6a255357f89c569 *DISC1.iso

This .md5 file is then imported into the database using the Import Disc Hashes
option under the File menu.

When you select this option you will will be asked if you want to remove all existing
hashes from the database first. Your choices are:

1. Yes - you want to replace all existing hash/filename mappings in the database
with the ones you are about to import. This deletes all existing hash/filename
entries first and then imports what ever is in the supplied .md5 file. This is a
fresh start so you will have to run md5sum over your entire directory of disc
images, not just the ones that have changed.

2. No - you only want to add the new hashes. This just appends the contents of
the .md5 file to the database. The .md5 file should only contain the hashes
for the new discs to avoid duplicate filename entries.

Next a file open dialog will appear where you can select your .md5 file. Select the
file and click OK. A progress dialog will appear while the data is imported into the
database.

Once it has completed you will be returned to the main window. Open up a few
discs and check that filenames appear correctly.
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Discs

CDRDB stores the following information about a disc:

1. Title

2. Series Number (eg, Disc 1, Disc 2, etc)

3. Date

4. Disc Text (any useful information written on the discs label)

5. Disc code (For assigning a unique number to discs - eg, CD#0042)

6. Storage Location (eg, CD Rack 3)

7. Media Type (CD-R, CD-RW, DVD-ROM, etc)

8. Picture Filename (if pictures are taken of the discs with something like a
scanner)

9. Image Hash (an MD5 sum of the disc image .iso file)

4.1 Creating Disc Entries

New Disc entries in the database can be created by selecting the New Disc...
option from the Create menu. This will bring up the New Disc window (Figure 4.1)

The only special fields here are Media Type, Picture Filename and Image Hash.
You can put what ever you like in any of the other fields.
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Figure 4.1: The New Disc window

To edit the Media Type options, see Section 5.2.

The Picture Filename field is for entering the name of a picture of the discs label.
If you want to scan in a copy of the discs label this is where you can attach the
resulting picture file. The disc information window has a view button to bring up the
picture file.

The Image Hash field should contain an MD5 (or other) hash of the disc im-
age (.iso) file. This is used to match database entries up to filenames later. To
compute this value run a utility like md5sum or MD5Summer (http://www.
md5summer.org over the .iso file and enter the value it gives you in this field.

For more details on how hashes are used to identify files, see chapter 3.

http://www.md5summer.org
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4.2 Viewing Discs

To view information a disc, find its entry in the table on the Main Window and double
click on it. This will bring up the Disc Information window (figure 4.2). This window
looks mostly the same as the Add Disc window except:

1. All of the fields are read-only (you can’t edit discs here).

2. There is a View button next to the Picture Filename field.

3. The Image Hash box has been replaced with an Image Files table.

4. There is a Close button instead of OK/Cancel.

If there is a picture filename for this disc, clicking the View button will open it in
your default image editor. By default CDRDB looks in the current directory for
image files. To change this, see section 5.3.1.

The Image Files table down the bottom of the window should display two columns;
Hash and Filename. The values in the Hash column should all be the same and
will match the Image Hash you entered when creating the database entry. If there
is more than one file listed here then you probably have multiple identical copies
of the disc which were entered in the database or you imaged the disc more than
once.

4.3 Editing Discs

There is no proper way of editing existing records in the database as it is not normal
for discs to be changed once they have been created. However, if a mistake was
made when entering a disc into the database it is possible to correct it but it is not
as easy.

To edit data in the database, choose the Edit Data option under the Tools menu.
This will bring up the Edit Raw Data window (Figure 4.3).

This window allows you to edit any entry in the database. Just double click on a
cell to edit its contents. Any changes you make will be saved to the database when
you click OK or discarded when you click Cancel.
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Figure 4.2: The Disc Information window

You can actually create new Disc entries in the database using this window by
clicking on the Insert Record button at the top of the window. It will normally be
easier to use the New Disc dialog though.
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Figure 4.3: The Edit Raw Data window
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Maintenance

A few database maintenance tools are available under the Tools menu. Mostly you
wont need to use them although it may be useful to set some information in the
Database Properties dialog (Section 5.1).

5.1 Properties

The Database Properties window (figure 5.1) can be accessed using the Database
Properties... option in the Tools menu.

At the top of the window there are a few details about the database itself. These
are:

Database Type The sort of database this is. It should always
read "CDRIMGDB". CDRDB will refuse to open
anything else.

Generator The name of the program that created the
database. This will normally be "CDRDB".

Version The database format version. This indicates the
features available in the database. It will likely
affect the Minimum Program Version.

Minimum Program Version This is the minimum compatible version of
CDRDB. Any versions older than this won’t be
able to open the database.

In addition to this information, there are two fields you can set yourself - Author and
Comments. You can write what ever you like here.
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Figure 5.1: The Database Properties window

5.2 Media Types

To configure the options available in the Media Type combo box in the New Disc
window, select the Maintain Media Types... option from the Tools menu. This will
display the Media Types Maintenance window (figure 5.2). Using this window you
can edit existing Media Types and insert new ones. There is no delete functionality.

To edit a value, just double click on the table cell. To insert a new Media Type, click
on the Insert New Entry button. This will insert a new row at the bottom of the
table.

The Name column is the value shown in the combo box. The Description column
is not used at this time but it may be shown in the user interface at some point in
the future.

Clicking on the OK button will save your changes, Cancel will discard them.
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Figure 5.2: The Media Types Maintenance window

5.3 Configuration

At this time CDRDB is still a very basic program and as such there is only one
configuration option. There is no graphical interface for setting this value. Instead,
open CDRDB.ini in the programs directory in notepad to change settings.

5.3.1 Default Image Directory

The DefaultImageDir setting controls where CDRDB looks for picture files
when you click on the View button in the Disc Information window. If no value is
set the programs directory will be used instead.

To set this value, insert a line such as the following into CDRDB.ini:
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DefaultImageDir=C:\disc_images\pics
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